kernel: bump 3.18 to 3.18.121
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 12fcacb58554cf6d8329ce846e881b42945ac40c..6c0623cb9bfac4d1169c7fb8cbdae6e47ae40ba6 100644 (file)
@@ -6,20 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-LINUX_VERSION:=3.10.12
-
-include $(INCLUDE_DIR)/target.mk
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
+MAINTAINER:=John Crispin <john@phrozen.org>
 
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))