ar71xx: move dragino2 from legacy to generic
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 4d79a1aa792e6d61214275bb8193345c8ead18f8..7218222e2f7198b43d63444b5228c589da31d143 100644 (file)
@@ -1,25 +1,26 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+FEATURES:=squashfs ext4 initramfs pci usb
+CPU_TYPE:=octeon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.37.4
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))