octeon: update to 3.14
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 4c43148e6cf2dc3fd8a4da6e1b7c50333b8bc101..7b9163cdc4156f44bfe06fdf6bcfa64c5eeaabe7 100644 (file)
@@ -1,22 +1,24 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs jffs2 ext4 pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.30.1
+LINUX_VERSION:=3.10.49
+LINUX_VERSION:=3.14.14
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.