mediatek: add support for the NAND-ePHY board
[openwrt/openwrt.git] / target / linux / omap24xx / Makefile
index b3e54d31be0ea754e87007cf77f2c7e22a08155b..5dd5938db2301fcea29559d29dd5ddea9db56a3c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,17 +11,16 @@ BOARD:=omap24xx
 BOARDNAME:=TI OMAP24xx
 MAINTAINER:=Michael Buesch <m@bues.ch>
 FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
+CPU_TYPE:=arm1136j-s
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=4.1
+
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        TI OMAP-24xx
 endef
 
-CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s
-
-KERNELNAME:="zImage"
-
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))