mvebu: set fan_ctrl.sh only on mamba
[openwrt/openwrt.git] / target / linux / orion / image / Makefile
index a8c2fbafff8275a4523a2079244a988bc56956ec..058519f7203395aa195965dd30bc21f844b159a1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,31 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/Prepare
-#
-# XXX - FIXME, we hardcode for the WRT350N v2 for now
-#
-       echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/zImage
-       cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/zImage
-endef
-
-define Image/BuildKernel
-       $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
-       -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
-       -d $(KDIR)/zImage $(KDIR)/uImage
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-endef
-
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-endef
-
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       ( \
-               dd if=$(KDIR)/uImage bs=1024k conv=sync; \
-               dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
-endef
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))