lantiq: dts: Add the reset line for the PCI controller
[openwrt/openwrt.git] / target / linux / oxnas / Makefile
index 32bcab869b14d8d4c24d88735edd67687ca1c000..f52a0ceca5fa022fec84cd0bb5d323aa8cafe06c 100644 (file)
@@ -1,28 +1,19 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=oxnas
-BOARDNAME:=PLXTECH/Oxford NAS782x/OX82x
+BOARDNAME:=PLXTECH/Oxford NAS782x/OX8xx
+SUBTARGETS:=ox810se ox820
+FEATURES:=gpio ramdisk rtc squashfs
 DEVICE_TYPE:=nas
-FEATURES:=gpio nand pcie usb ramdisk rtc squashfs ubifs
-CPU_TYPE:=mpcore
 
-MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
-
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=5.10
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-ata-core kmod-ata-oxnas-sata kmod-button-hotplug \
-       kmod-input-gpio-keys-polled kmod-leds-gpio kmod-usb2-oxnas \
-       uboot-envtools uboot-oxnas-ox820
+       kmod-button-hotplug kmod-input-gpio-keys-polled \
+       kmod-leds-gpio uboot-envtools
 
 KERNELNAME:=zImage dtbs