treewide: provide global default for SUPPORTED_DEVICES
[openwrt/openwrt.git] / target / linux / oxnas / image / ox820.mk
index 0bc8797da8e692a5827cf61e64caa8b444c6beba..8dea842503578edf60ea26790094174d780ec685 100644 (file)
@@ -10,7 +10,6 @@ define Device/Default
   SUBPAGESIZE := 512
   FILESYSTEMS := squashfs ubifs
   PROFILES := Default
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   DEVICE_DTS := ox820-$(subst _,-,$(1))
   KERNEL := kernel-bin | append-dtb | uImage none
   IMAGES := ubinized.bin sysupgrade.tar
@@ -50,8 +49,8 @@ define Device/cloudengines_pogoplugpro
   DEVICE_VENDOR := Cloud Engines
   DEVICE_MODEL := PogoPlug Pro (with mPCIe)
   SUPPORTED_DEVICES += pogoplug-pro
-  DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport kmod-rt2800-pci \
-       wpad-basic
+  DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport \
+       kmod-ata-oxnas-sata kmod-rt2800-pci wpad-basic-wolfssl
 endef
 TARGET_DEVICES += cloudengines_pogoplugpro
 
@@ -59,7 +58,8 @@ define Device/cloudengines_pogoplug-series-3
   DEVICE_VENDOR := Cloud Engines
   DEVICE_MODEL := PogoPlug Series V3 (without mPCIe)
   SUPPORTED_DEVICES += cloudengines,pogoplugv3 pogoplug-v3
-  DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport \
+       kmod-ata-oxnas-sata
 endef
 TARGET_DEVICES += cloudengines_pogoplug-series-3
 
@@ -67,14 +67,10 @@ define Device/shuttle_kd20
   DEVICE_VENDOR := Shuttle
   DEVICE_MODEL := KD20
   SUPPORTED_DEVICES += kd20
-  KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
-  KERNEL_INITRAMFS_SUFFIX := .tar.gz
-  KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | \
-       encrypt-3des sohmuntitnlaes
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb3 kmod-usb-ledtrig-usbport \
-       kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper kmod-hwmon-gpiofan \
-       kmod-ata-oxnas-sata kmod-md-mod kmod-md-raid0 kmod-md-raid1 kmod-fs-ext4 \
-       kmod-fs-xfs
+       kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper kmod-hwmon-drivetemp \
+       kmod-hwmon-gpiofan kmod-ata-oxnas-sata kmod-md-mod kmod-md-raid0 \
+       kmod-md-raid1 kmod-fs-ext4 kmod-fs-xfs
 endef
 TARGET_DEVICES += shuttle_kd20