ar71xx: use the new ar7240 switch driver on the DIR-600-A1 as well (fixes #7563)
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index 1c13f4ce9a6c84cb8a8344f81350b33a9400dd70..32a198f2d8ff7ea5e4a390653d685046bc0ed98c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,16 +10,14 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.26.3
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
-
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))