ramips: Added preinit scriptlet to set vars based on cpuinfo during preinit_main...
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index be1d122f5b4ad5b99c69b3c24c129c2d79013ac5..0d375b5960b485d815a5c71577972ab88c07fca9 100644 (file)
@@ -11,12 +11,12 @@ BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT305x
 SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-FEATURES:=squashfs broken
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.9
+LINUX_VERSION:=2.6.34
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-leds-gpio
+DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT305x based boards.