ipq40xx: only include ath10k-board-qca4019 for the generic subtarget
[openwrt/staging/chunkeey.git] / target / linux / ramips / Makefile
index 60302871e955e25caacf5138cab1c069d2a372e5..7d34dfe6761b158759be9c25e9cb0ee97a94f3f2 100644 (file)
@@ -1,28 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2008-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=mt7620 mt7621 mt76x8 rt288x rt305x rt3883
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.3
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-leds-gpio kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))