ramips: mt7621: add support for Xiaomi Mi Router 4
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index ff39cbf39a6df20b8fc0167cde0dd4b974c588b3..005a9bdc55d86154ec51087159f7bb2ab41f6251 100644 (file)
@@ -1277,6 +1277,14 @@ define Device/xiaomi_mi-router-3-pro
 endef
 TARGET_DEVICES += xiaomi_mi-router-3-pro
 
+define Device/xiaomi_mi-router-4
+  $(Device/xiaomi_nand_separate)
+  DEVICE_MODEL := Mi Router 4
+  IMAGE_SIZE := 124416k
+  DEVICE_PACKAGES += kmod-mt7603 kmod-mt76x2
+endef
+TARGET_DEVICES += xiaomi_mi-router-4
+
 define Device/xiaomi_mi-router-4a-gigabit
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)