ramips: update i2c drivers
[openwrt/openwrt.git] / target / linux / ramips / modules.mk
index bfb9bcd826339771754911c108c8de326e351203..15017d01d9ff7f044506b89b912fd22bb73f3ff6 100644 (file)
@@ -1,11 +1,31 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 OTHER_MENU:=Other modules
+
+define KernelPackage/pwm-mediatek
+  SUBMENU:=Other modules
+  TITLE:=MT7628 PWM
+  DEPENDS:=@(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+  KCONFIG:= \
+       CONFIG_PWM=y \
+       CONFIG_PWM_MEDIATEK \
+       CONFIG_PWM_SYSFS=y
+  FILES:= \
+       $(LINUX_DIR)/drivers/pwm/pwm-mediatek.ko
+  AUTOLOAD:=$(call AutoProbe,pwm-mediatek)
+endef
+
+define KernelPackage/pwm-mediatek/description
+  Kernel modules for MediaTek Pulse Width Modulator
+endef
+
+$(eval $(call KernelPackage,pwm-mediatek))
+
 define KernelPackage/sdhci-mt7620
   SUBMENU:=Other modules
   TITLE:=MT7620 SDCI
@@ -73,30 +93,3 @@ define KernelPackage/sound-mt7620/description
 endef
 
 $(eval $(call KernelPackage,sound-mt7620))
-
-
-define KernelPackage/sound-mtk
-  TITLE:=Mediatek I2S Alsa Driver
-  DEPENDS:= +kmod-sound-soc-core +kmod-regmap +kmod-i2c-ralink @(TARGET_ramips_mt7628||TARGET_ramips_mt7688||TARGET_ramips_mt7620)
-  KCONFIG:= \
-       CONFIG_SND_MT76XX_SOC \
-       CONFIG_SND_MT76XX_I2S \
-       CONFIG_SND_MT76XX_PCM \
-       CONFIG_SND_SOC_WM8960
-  FILES:= \
-       $(LINUX_DIR)/sound/soc/mtk/ralink_gdma.ko \
-       $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-i2s-ctl.ko \
-       $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-i2s.ko \
-       $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-pcm.ko \
-       $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-machine.ko \
-       $(LINUX_DIR)/sound/soc/mtk/i2c_wm8960.ko \
-       $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
-  AUTOLOAD:=$(call AutoLoad,90,ralink_gdma snd-soc-wm8960 i2c_wm8960 snd-soc-mt76xx-i2s-ctl snd-soc-mt76xx-i2s snd-soc-mt76xx-pcm snd-soc-mt76xx-machine)
-  $(call AddDepends/sound)
-endef
-
-define KernelPackage/sound-mtk/description
- Alsa modules for ralink i2s controller.
-endef
-
-$(eval $(call KernelPackage,sound-mtk))