kernel: update linux 3.8 to 3.8.6
[openwrt/openwrt.git] / target / linux / ramips / patches-3.8 / 0109-MIPS-ralink-adds-support-for-RT3883-SoC-family.patch
index d68d3fdaeb4f02d5be016cc17d92dabe2bf8fa87..3d822f4f52c91a4b57818573461c2b73c067eba4 100644 (file)
@@ -18,9 +18,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 arch/mips/include/asm/mach-ralink/rt3883.h
  create mode 100644 arch/mips/ralink/rt3883.c
 
-diff --git a/arch/mips/include/asm/mach-ralink/rt3883.h b/arch/mips/include/asm/mach-ralink/rt3883.h
-new file mode 100644
-index 0000000..b91c6c1
 --- /dev/null
 +++ b/arch/mips/include/asm/mach-ralink/rt3883.h
 @@ -0,0 +1,247 @@
@@ -271,8 +268,6 @@ index 0000000..b91c6c1
 +#define RT3883_FLASH_CFG_WIDTH_32BIT  0x2
 +
 +#endif /* _RT3883_REGS_H_ */
-diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
-index 0d312fc..f21cbaa 100644
 --- a/arch/mips/ralink/Kconfig
 +++ b/arch/mips/ralink/Kconfig
 @@ -15,6 +15,11 @@ choice
@@ -287,11 +282,9 @@ index 0d312fc..f21cbaa 100644
  endchoice
  
  choice
-diff --git a/arch/mips/ralink/Makefile b/arch/mips/ralink/Makefile
-index ce83bfc..87f6ca9 100644
 --- a/arch/mips/ralink/Makefile
 +++ b/arch/mips/ralink/Makefile
-@@ -10,6 +10,7 @@ obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o
+@@ -10,6 +10,7 @@ obj-y := prom.o of.o reset.o clk.o irq.o
  
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
@@ -299,11 +292,9 @@ index ce83bfc..87f6ca9 100644
  
  obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
  
-diff --git a/arch/mips/ralink/Platform b/arch/mips/ralink/Platform
-index 3f49e51..f67c08d 100644
 --- a/arch/mips/ralink/Platform
 +++ b/arch/mips/ralink/Platform
-@@ -13,3 +13,8 @@ load-$(CONFIG_SOC_RT288X)    += 0xffffffff88000000
+@@ -13,3 +13,8 @@ load-$(CONFIG_SOC_RT288X)    += 0xffffffff8
  # Ralink RT305x
  #
  load-$(CONFIG_SOC_RT305X)     += 0xffffffff80000000
@@ -312,9 +303,6 @@ index 3f49e51..f67c08d 100644
 +# Ralink RT3883
 +#
 +load-$(CONFIG_SOC_RT3883)     += 0xffffffff80000000
-diff --git a/arch/mips/ralink/rt3883.c b/arch/mips/ralink/rt3883.c
-new file mode 100644
-index 0000000..10a8150
 --- /dev/null
 +++ b/arch/mips/ralink/rt3883.c
 @@ -0,0 +1,207 @@
@@ -525,6 +513,3 @@ index 0000000..10a8150
 +              (id >> RT3883_REVID_VER_ID_SHIFT) & RT3883_REVID_VER_ID_MASK,
 +              (id & RT3883_REVID_ECO_ID_MASK));
 +}
--- 
-1.7.10.4
-