kernel: update linux 3.8 to 3.8.6
[openwrt/openwrt.git] / target / linux / ramips / patches-3.8 / 0204-owrt-MIPS-ralink-add-usb-platform-support.patch
index 7b9e1a366a06d8ac7aad0992505206f30825b652..4ff80e83e14e3b6e6bbb3c26daf5544e3e57e906 100644 (file)
@@ -19,8 +19,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 arch/mips/ralink/rt305x-usb.c
  create mode 100644 arch/mips/ralink/rt3883-usb.c
 
-diff --git a/arch/mips/ralink/Makefile b/arch/mips/ralink/Makefile
-index cae7d88..8572538 100644
 --- a/arch/mips/ralink/Makefile
 +++ b/arch/mips/ralink/Makefile
 @@ -9,8 +9,8 @@
@@ -34,19 +32,15 @@ index cae7d88..8572538 100644
  obj-$(CONFIG_SOC_MT7620) += mt7620.o
  
  obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-diff --git a/arch/mips/ralink/common.h b/arch/mips/ralink/common.h
-index ed99f23..14a101c 100644
 --- a/arch/mips/ralink/common.h
 +++ b/arch/mips/ralink/common.h
-@@ -43,5 +43,6 @@ extern void prom_soc_init(struct ralink_soc_info *soc_info);
+@@ -43,5 +43,6 @@ extern void prom_soc_init(struct ralink_
  __iomem void *plat_of_remap_node(const char *node);
  
  void ralink_pinmux(void);
 +void ralink_usb_platform(void);
  
  #endif /* _RALINK_COMMON_H__ */
-diff --git a/arch/mips/ralink/mt7620.c b/arch/mips/ralink/mt7620.c
-index 9d0dc8b..19b28c5 100644
 --- a/arch/mips/ralink/mt7620.c
 +++ b/arch/mips/ralink/mt7620.c
 @@ -146,6 +146,11 @@ struct ralink_pinmux rt_pinmux = {
@@ -61,8 +55,6 @@ index 9d0dc8b..19b28c5 100644
  void __init ralink_clk_init(void)
  {
        unsigned long cpu_rate, sys_rate;
-diff --git a/arch/mips/ralink/of.c b/arch/mips/ralink/of.c
-index ecf1482..f438145 100644
 --- a/arch/mips/ralink/of.c
 +++ b/arch/mips/ralink/of.c
 @@ -102,6 +102,7 @@ static int __init plat_of_setup(void)
@@ -73,9 +65,6 @@ index ecf1482..f438145 100644
  
        return 0;
  }
-diff --git a/arch/mips/ralink/rt305x-usb.c b/arch/mips/ralink/rt305x-usb.c
-new file mode 100644
-index 0000000..793fc82
 --- /dev/null
 +++ b/arch/mips/ralink/rt305x-usb.c
 @@ -0,0 +1,120 @@
@@ -199,9 +188,6 @@ index 0000000..793fc82
 +                              &rt3352_ehci_data, &rt3352_ehci_dmamask);
 +      }
 +}
-diff --git a/arch/mips/ralink/rt3883-usb.c b/arch/mips/ralink/rt3883-usb.c
-new file mode 100644
-index 0000000..1d948a9
 --- /dev/null
 +++ b/arch/mips/ralink/rt3883-usb.c
 @@ -0,0 +1,118 @@
@@ -323,6 +309,3 @@ index 0000000..1d948a9
 +      ralink_add_usb("ehci-platform",
 +                      &rt3883_ehci_data, &rt3883_ehci_dmamask);
 +}
--- 
-1.7.10.4
-