realtek: rtl931x: drop CONFIG_NO_EXCEPT_FILL hack
[openwrt/openwrt.git] / target / linux / realtek / patches-5.15 / 312-rt9313-support.patch
index 516bca2b6ef919a099167df38d12fcc0689921d4..e8edc996f3d0c784d5b714f09dbbb76f7ab2298d 100644 (file)
@@ -16,7 +16,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
 
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -307,14 +307,24 @@ endif
+@@ -310,14 +310,24 @@ endif
  
  KBUILD_AFLAGS += $(cflags-y)
  KBUILD_CFLAGS += $(cflags-y)
@@ -43,23 +43,6 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
  ifdef CONFIG_32BIT
  bootvars-y    += ADDR_BITS=32
  endif
---- a/arch/mips/kernel/head.S
-+++ b/arch/mips/kernel/head.S
-@@ -60,12 +60,14 @@
-       .endm
- #ifndef CONFIG_NO_EXCEPT_FILL
-+#ifndef CONFIG_RTL931X
-       /*
-        * Reserved space for exception handlers.
-        * Necessary for machines which link their kernels at KSEG0.
-        */
-       .fill   0x400
- #endif
-+#endif
- EXPORT(_stext)
 --- a/arch/mips/kernel/vmlinux.lds.S
 +++ b/arch/mips/kernel/vmlinux.lds.S
 @@ -55,7 +55,11 @@ SECTIONS