brcm47xx: backport two MIPS nvram.c patches
[openwrt/openwrt.git] / target / linux / realview / Makefile
index 0bd94ac0d65fe08d0dd2a8acc3baf5d6613cdc10..5b0a0408a257eda2754c783b0558905044814d3e 100644 (file)
@@ -9,10 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
-FEATURES:=squashfs jffs2 fpu
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+FEATURES:=fpu ramdisk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.37.6
+KERNEL_PATCHVER:=3.18
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))