rockchip: refresh NanoPi R2S patches
[openwrt/openwrt.git] / target / linux / rockchip / patches-5.4 / 001-rockchip-rk3328-Add-support-for-FriendlyARM-NanoPi-R.patch
index 904a2f31b6b0068d45b870cf7eb0da3edd1f4a4f..69ee8a7c3a43be425e385c7ed5092d97fd8b81e0 100644 (file)
@@ -1,4 +1,4 @@
-From 749cbb7b1a4bc2244b6af8cd7d8b471d4e33c80f Mon Sep 17 00:00:00 2001
+From 0720be5371c806c1b89936984a321248fa739bea Mon Sep 17 00:00:00 2001
 From: David Bauer <mail@david-bauer.net>
 Date: Fri, 10 Jul 2020 15:57:46 +0200
 Subject: [PATCH] rockchip: rk3328: Add support for FriendlyARM NanoPi R2S
@@ -17,8 +17,8 @@ WAN - LAN - SYS LED
 Signed-off-by: David Bauer <mail@david-bauer.net>
 ---
  arch/arm64/boot/dts/rockchip/Makefile         |   1 +
- .../boot/dts/rockchip/rk3328-nanopi-r2s.dts   | 334 ++++++++++++++++++
- 2 files changed, 335 insertions(+)
+ .../boot/dts/rockchip/rk3328-nanopi-r2s.dts   | 368 ++++++++++++++++++
+ 2 files changed, 369 insertions(+)
  create mode 100644 arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
 
 --- a/arch/arm64/boot/dts/rockchip/Makefile
@@ -33,7 +33,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-evb-act8846.dtb
 --- /dev/null
 +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts
-@@ -0,0 +1,334 @@
+@@ -0,0 +1,368 @@
 +// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
 +/*
 + * Copyright (c) 2020 David Bauer <mail@david-bauer.net>
@@ -46,92 +46,91 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +#include "rk3328.dtsi"
 +
 +/ {
-+      model = "FriendlyARM NanoPi R2S";
++      model = "FriendlyElec NanoPi R2S";
 +      compatible = "friendlyarm,nanopi-r2s", "rockchip,rk3328";
 +
 +      chosen {
 +              stdout-path = "serial2:1500000n8";
 +      };
 +
-+      gmac_clkin: external-gmac-clock {
++      gmac_clkgmac-clock {
 +              compatible = "fixed-clock";
 +              clock-frequency = <125000000>;
-+              clock-output-names = "gmac_clkin";
++              clock-output-names = "gmac_clk";
 +              #clock-cells = <0>;
 +      };
 +
-+      vcc_sd: sdmmc-regulator {
-+              compatible = "regulator-fixed";
-+              gpio = <&gpio0 RK_PD6 GPIO_ACTIVE_LOW>;
-+              pinctrl-names = "default";
-+              pinctrl-0 = <&sdmmc0m1_gpio>;
-+              regulator-name = "vcc_sd";
-+              regulator-min-microvolt = <3300000>;
-+              regulator-max-microvolt = <3300000>;
-+              vin-supply = <&vcc_io>;
-+      };
-+
-+      vcc_sdio: sdmmcio-regulator {
-+              compatible = "regulator-gpio";
-+              gpios = <&gpio1 RK_PD4 GPIO_ACTIVE_HIGH>;
-+              enable-active-high;
-+              states = <1800000 0x1
-+                        3300000 0x0>;
++      keys {
++              compatible = "gpio-keys";
++              pinctrl-0 = <&reset_button_pin>;
 +              pinctrl-names = "default";
-+              pinctrl-0 = <&sdio_vcc_pin>;
-+              regulator-always-on;
-+              regulator-min-microvolt = <1800000>;
-+              regulator-max-microvolt = <3300000>;
-+              regulator-name = "vcc_sdio";
-+              regulator-settling-time-us = <5000>;
-+              regulator-type = "voltage";
-+              vin-supply = <&vcc_io>;
-+      };
 +
-+      vcc_sys: vcc-sys {
-+              compatible = "regulator-fixed";
-+              regulator-name = "vcc_sys";
-+              regulator-always-on;
-+              regulator-boot-on;
-+              regulator-min-microvolt = <5000000>;
-+              regulator-max-microvolt = <5000000>;
++              reset {
++                      label = "reset";
++                      gpios = <&gpio0 RK_PA0 GPIO_ACTIVE_LOW>;
++                      linux,code = <KEY_RESTART>;
++                      debounce-interval = <50>;
++              };
 +      };
 +
 +      leds {
 +              compatible = "gpio-leds";
-+
++              pinctrl-0 = <&lan_led_pin>,  <&sys_led_pin>, <&wan_led_pin>;
 +              pinctrl-names = "default";
-+              pinctrl-0 = <&led_pins>;
 +
-+              sys {
-+                      gpios = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;
-+                      label = "nanopi-r2s:red:sys";
-+              };
-+
-+              lan {
++              lan_led: led-0 {
 +                      gpios = <&gpio2 RK_PB7 GPIO_ACTIVE_HIGH>;
 +                      label = "nanopi-r2s:green:lan";
 +              };
 +
-+              wan {
++              sys_led: led-1 {
++                      gpios = <&gpio0 RK_PA2 GPIO_ACTIVE_HIGH>;
++                      label = "nanopi-r2s:red:sys";
++              };
++
++              wan_led: led-2 {
 +                      gpios = <&gpio2 RK_PC2 GPIO_ACTIVE_HIGH>;
 +                      label = "nanopi-r2s:green:wan";
 +              };
 +      };
 +
-+      gpio_keys {
-+              compatible = "gpio-keys-polled";
-+              poll-interval = <100>;
++      vcc_io_sdio: sdmmcio-regulator {
++              compatible = "regulator-gpio";
++              enable-active-high;
++              gpios = <&gpio1 RK_PD4 GPIO_ACTIVE_HIGH>;
++              pinctrl-0 = <&sdio_vcc_pin>;
++              pinctrl-names = "default";
++              regulator-name = "vcc_io_sdio";
++              regulator-always-on;
++              regulator-min-microvolt = <1800000>;
++              regulator-max-microvolt = <3300000>;
++              regulator-settling-time-us = <5000>;
++              regulator-type = "voltage";
++              startup-delay-us = <2000>;
++              states = <1800000 0x1
++                        3300000 0x0>;
++              vin-supply = <&vcc_io_33>;
++      };
 +
++      vcc_sd: sdmmc-regulator {
++              compatible = "regulator-fixed";
++              gpio = <&gpio0 RK_PD6 GPIO_ACTIVE_LOW>;
++              pinctrl-0 = <&sdmmc0m1_gpio>;
 +              pinctrl-names = "default";
-+              pinctrl-0 = <&button_pins>;
++              regulator-name = "vcc_sd";
++              regulator-boot-on;
++              regulator-min-microvolt = <3300000>;
++              regulator-max-microvolt = <3300000>;
++              vin-supply = <&vcc_io_33>;
++      };
 +
-+              reset {
-+                      label = "Reset Button";
-+                      gpios = <&gpio0 RK_PA0 GPIO_ACTIVE_LOW>;
-+                      linux,code = <KEY_RESTART>;
-+                      debounce-interval = <50>;
-+              };
++      vdd_5v: vdd-5v {
++              compatible = "regulator-fixed";
++              regulator-name = "vdd_5v";
++              regulator-always-on;
++              regulator-boot-on;
++              regulator-min-microvolt = <5000000>;
++              regulator-max-microvolt = <5000000>;
 +      };
 +};
 +
@@ -153,19 +152,16 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +
 +&gmac2io {
 +      assigned-clocks = <&cru SCLK_MAC2IO>, <&cru SCLK_MAC2IO_EXT>;
-+      assigned-clock-parents = <&gmac_clkin>, <&gmac_clkin>;
++      assigned-clock-parents = <&gmac_clk>, <&gmac_clk>;
 +      clock_in_out = "input";
-+      phy-supply = <&vcc_io>;
 +      phy-handle = <&rtl8211e>;
 +      phy-mode = "rgmii";
-+      pinctrl-names = "default";
++      phy-supply = <&vcc_io_33>;
 +      pinctrl-0 = <&rgmiim1_pins>;
++      pinctrl-names = "default";
++      rx_delay = <0x18>;
 +      snps,aal;
-+      snps,reset-gpio = <&gpio1 RK_PC2 GPIO_ACTIVE_LOW>;
-+      snps,reset-active-low;
-+      snps,reset-delays-us = <0 10000 50000>;
 +      tx_delay = <0x24>;
-+      rx_delay = <0x18>;
 +      status = "okay";
 +
 +      mdio {
@@ -173,8 +169,13 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +              #address-cells = <1>;
 +              #size-cells = <0>;
 +
-+              rtl8211e: ethernet-phy@0 {
-+                      reg = <0>;
++              rtl8211e: ethernet-phy@1 {
++                      reg = <1>;
++                      pinctrl-0 = <&eth_phy_reset_pin>;
++                      pinctrl-names = "default";
++                      reset-assert-us = <10000>;
++                      reset-deassert-us = <50000>;
++                      reset-gpios = <&gpio1 RK_PC2 GPIO_ACTIVE_LOW>;
 +              };
 +      };
 +};
@@ -182,35 +183,36 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +&i2c1 {
 +      status = "okay";
 +
-+      rk805: rk805@18 {
++      rk805: pmic@18 {
 +              compatible = "rockchip,rk805";
 +              reg = <0x18>;
-+              interrupt-parent = <&gpio2>;
-+              interrupts = <6 IRQ_TYPE_LEVEL_LOW>;
++              interrupt-parent = <&gpio1>;
++              interrupts = <24 IRQ_TYPE_LEVEL_LOW>;
 +              #clock-cells = <1>;
 +              clock-output-names = "xin32k", "rk805-clkout2";
 +              gpio-controller;
 +              #gpio-cells = <2>;
-+              pinctrl-names = "default";
 +              pinctrl-0 = <&pmic_int_l>;
++              pinctrl-names = "default";
 +              rockchip,system-power-controller;
 +              wakeup-source;
 +
-+              vcc1-supply = <&vcc_sys>;
-+              vcc2-supply = <&vcc_sys>;
-+              vcc3-supply = <&vcc_sys>;
-+              vcc4-supply = <&vcc_sys>;
-+              vcc5-supply = <&vcc_io>;
-+              vcc6-supply = <&vcc_sys>;
++              vcc1-supply = <&vdd_5v>;
++              vcc2-supply = <&vdd_5v>;
++              vcc3-supply = <&vdd_5v>;
++              vcc4-supply = <&vdd_5v>;
++              vcc5-supply = <&vcc_io_33>;
++              vcc6-supply = <&vdd_5v>;
 +
 +              regulators {
-+                      vdd_logic: DCDC_REG1 {
-+                              regulator-name = "vdd_logic";
++                      vdd_log: DCDC_REG1 {
++                              regulator-name = "vdd_log";
++                              regulator-always-on;
++                              regulator-boot-on;
 +                              regulator-min-microvolt = <712500>;
 +                              regulator-max-microvolt = <1450000>;
 +                              regulator-ramp-delay = <12500>;
-+                              regulator-always-on;
-+                              regulator-boot-on;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <1000000>;
@@ -219,11 +221,12 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +
 +                      vdd_arm: DCDC_REG2 {
 +                              regulator-name = "vdd_arm";
++                              regulator-always-on;
++                              regulator-boot-on;
 +                              regulator-min-microvolt = <712500>;
 +                              regulator-max-microvolt = <1450000>;
 +                              regulator-ramp-delay = <12500>;
-+                              regulator-always-on;
-+                              regulator-boot-on;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <950000>;
@@ -234,17 +237,19 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +                              regulator-name = "vcc_ddr";
 +                              regulator-always-on;
 +                              regulator-boot-on;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                              };
 +                      };
 +
-+                      vcc_io: DCDC_REG4 {
-+                              regulator-name = "vcc_io";
-+                              regulator-min-microvolt = <3300000>;
-+                              regulator-max-microvolt = <3300000>;
++                      vcc_io_33: DCDC_REG4 {
++                              regulator-name = "vcc_io_33";
 +                              regulator-always-on;
 +                              regulator-boot-on;
++                              regulator-min-microvolt = <3300000>;
++                              regulator-max-microvolt = <3300000>;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <3300000>;
@@ -253,10 +258,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +
 +                      vcc_18: LDO_REG1 {
 +                              regulator-name = "vcc_18";
-+                              regulator-min-microvolt = <1800000>;
-+                              regulator-max-microvolt = <1800000>;
 +                              regulator-always-on;
 +                              regulator-boot-on;
++                              regulator-min-microvolt = <1800000>;
++                              regulator-max-microvolt = <1800000>;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <1800000>;
@@ -265,10 +271,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +
 +                      vcc18_emmc: LDO_REG2 {
 +                              regulator-name = "vcc18_emmc";
-+                              regulator-min-microvolt = <1800000>;
-+                              regulator-max-microvolt = <1800000>;
 +                              regulator-always-on;
 +                              regulator-boot-on;
++                              regulator-min-microvolt = <1800000>;
++                              regulator-max-microvolt = <1800000>;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <1800000>;
@@ -277,10 +284,11 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +
 +                      vdd_10: LDO_REG3 {
 +                              regulator-name = "vdd_10";
-+                              regulator-min-microvolt = <1000000>;
-+                              regulator-max-microvolt = <1000000>;
 +                              regulator-always-on;
 +                              regulator-boot-on;
++                              regulator-min-microvolt = <1000000>;
++                              regulator-max-microvolt = <1000000>;
++
 +                              regulator-state-mem {
 +                                      regulator-on-in-suspend;
 +                                      regulator-suspend-microvolt = <1000000>;
@@ -291,35 +299,46 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +};
 +
 +&io_domains {
-+      status = "okay";
-+
-+      vccio1-supply = <&vcc_io>;
++      pmuio-supply = <&vcc_io_33>;
++      vccio1-supply = <&vcc_io_33>;
 +      vccio2-supply = <&vcc18_emmc>;
-+      vccio3-supply = <&vcc_sdio>;
++      vccio3-supply = <&vcc_io_sdio>;
 +      vccio4-supply = <&vcc_18>;
-+      vccio5-supply = <&vcc_io>;
-+      vccio6-supply = <&vcc_io>;
-+      pmuio-supply = <&vcc_io>;
++      vccio5-supply = <&vcc_io_33>;
++      vccio6-supply = <&vcc_io_33>;
++      status = "okay";
 +};
 +
 +&pinctrl {
-+      leds {
-+              led_pins: led-pins {
-+                      rockchip,pins = <0 RK_PA2 RK_FUNC_GPIO &pcfg_pull_none>,
-+                                                      <2 RK_PB7 RK_FUNC_GPIO &pcfg_pull_none>,
-+                                                      <2 RK_PC2 RK_FUNC_GPIO &pcfg_pull_none>;
++      button {
++              reset_button_pin: reset-button-pin {
++                      rockchip,pins = <0 RK_PA0 RK_FUNC_GPIO &pcfg_pull_none>;
 +              };
 +      };
 +
-+      button {
-+              button_pins: button-pins {
-+                      rockchip,pins = <0 RK_PA0 RK_FUNC_GPIO &pcfg_pull_none>;
++      ethernet-phy {
++              eth_phy_reset_pin: eth-phy-reset-pin {
++                      rockchip,pins = <1 RK_PC2 RK_FUNC_GPIO &pcfg_pull_down>;
++              };
++      };
++
++      leds {
++              lan_led_pin: lan-led-pin {
++                      rockchip,pins = <2 RK_PB7 RK_FUNC_GPIO &pcfg_pull_none>;
++              };
++
++              sys_led_pin: sys-led-pin {
++                      rockchip,pins = <0 RK_PA2 RK_FUNC_GPIO &pcfg_pull_none>;
++              };
++
++              wan_led_pin: wan-led-pin {
++                      rockchip,pins = <2 RK_PC2 RK_FUNC_GPIO &pcfg_pull_none>;
 +              };
 +      };
 +
 +      pmic {
 +              pmic_int_l: pmic-int-l {
-+                      rockchip,pins = <2 RK_PA6 RK_FUNC_GPIO &pcfg_pull_up>;
++                      rockchip,pins = <1 RK_PD0 RK_FUNC_GPIO &pcfg_pull_up>;
 +              };
 +      };
 +
@@ -330,16 +349,22 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +      };
 +};
 +
++&pwm2 {
++      status = "okay";
++};
++
 +&sdmmc {
 +      bus-width = <4>;
-+      cap-mmc-highspeed;
 +      cap-sd-highspeed;
 +      disable-wp;
-+      max-frequency = <150000000>;
++      pinctrl-0 = <&sdmmc0_clk>, <&sdmmc0_cmd>, <&sdmmc0_dectn>, <&sdmmc0_bus4>;
 +      pinctrl-names = "default";
-+      pinctrl-0 = <&sdmmc0_clk &sdmmc0_cmd &sdmmc0_dectn &sdmmc0_bus4>;
++      sd-uhs-sdr12;
++      sd-uhs-sdr25;
++      sd-uhs-sdr50;
++      sd-uhs-sdr104;
 +      vmmc-supply = <&vcc_sd>;
-+      vqmmc-supply = <&vcc_sdio>;
++      vqmmc-supply = <&vcc_io_sdio>;
 +      status = "okay";
 +};
 +
@@ -349,16 +374,25 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 +      status = "okay";
 +};
 +
-+&uart2 {
++&u2phy {
 +      status = "okay";
 +};
 +
-+&u2phy {
++&u2phy_host {
 +      status = "okay";
++};
 +
-+      u2phy_host: host-port {
-+              status = "okay";
-+      };
++&u2phy_otg {
++      status = "okay";
++};
++
++&uart2 {
++      status = "okay";
++};
++
++&usb20_otg {
++      status = "okay";
++      dr_mode = "host";
 +};
 +
 +&usb_host0_ehci {