kernel: update linux 3.3 to 3.3.7
[openwrt/openwrt.git] / target / linux / sibyte / Makefile
index 0226a99ad4ea83d49cc684c5e00a40a3d6baf8aa..2c30106ff7dfbce2b3521d4d4fa983d6053f23f2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
-FEATURES:=broken
+FEATURES:=fpu ramdisk broken
+CFLAGS:=-Os -pipe -march=sb1 -fno-caller-saves
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.26.7
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
+
 $(eval $(call BuildTarget))