generic: rtl8366: make rtl8366_set_vlan static
[openwrt/openwrt.git] / target / linux / sibyte / Makefile
index 35cdb37f2ec188409014d96ab0c3d8fd45a0c3c4..a166b6f2f2649c0339f29418a03dff04e9bfccee 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=sibyte
-BOARDNAME:=SiByte MIPS
-FEATURES:=broken
+BOARDNAME:=Broadcom/SiByte SB-1
+FEATURES:=fpu
+CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.32.14
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))