sunxi: bring up DSA b53 switch on Lamobo R1
[openwrt/openwrt.git] / target / linux / sunxi / Makefile
index cd936dcf26eeb4d5003b33d24d08719b11d479ff..1e07520db80f37e5e13aaff0380b7037e0997409 100644 (file)
@@ -1,29 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2013-2016 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display
-CPU_TYPE:=cortex-a8
-CPU_SUBTYPE:=vfpv3
-MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+BOARDNAME:=Allwinner A1x/A20/A3x/H3/H5/R40
+FEATURES:=fpu usb ext4 display rtc squashfs
+SUBTARGETS:=cortexa8 cortexa7 cortexa53
 
-LINUX_VERSION:=3.12.5
-KERNELNAME:="zImage dtbs"
-DEFAULT_PACKAGES += uboot-envtools uboot-sunxi
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
+KERNELNAME:=zImage dtbs
 
 # A10: Cortex-A8
 # A13: Cortex-A8
 # A20: dual Cortex-A7
 # A31: quad Cortex-A7
+# A80: octa Cortex-A15/A7
+# H3: quad Cortex-A7
+# R40: quad Cortex-A7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))