ath79: generic: add support for Realtek PHY
[openwrt/openwrt.git] / target / linux / sunxi / Makefile
index dd6785cfae5e59adf1056222e45d2339f68eaf7c..2a031c2df1c6bf5a6b038f79d3f7abf3578ad352 100644 (file)
@@ -1,21 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x/R40
-FEATURES:=fpu usb ext4 display rtc squashfs
+BOARDNAME:=Allwinner A1x/A20/A3x/H3/H5/R40
+FEATURES:=fpu usb ext4 display rootfs-part rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
-MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
-KERNEL_PATCHVER:=4.19
-KERNEL_TESTING_PATCHVER:=5.4
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
+
 KERNELNAME:=zImage dtbs
 
 # A10: Cortex-A8