x86: fix kmod-forcedeth package selection
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index a646e6e8a75f2cd18abb162430c0f9639f472f13..1b8d45f32aeea3e98a45403135a1bb226450237b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu boot-part rootfs-part
 SUBTARGETS:=generic legacy geode 64
 
 KERNEL_PATCHVER:=5.4
@@ -23,6 +23,9 @@ DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))