x86: fix kmod-forcedeth package selection
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index d1056109b97496a9e6e21e40f4962c5b4d6377cf..1b8d45f32aeea3e98a45403135a1bb226450237b 100644 (file)
@@ -1,24 +1,31 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk tgz
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu boot-part rootfs-part
+SUBTARGETS:=generic legacy geode 64
 
-LINUX_VERSION:=2.6.28.9
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))