x86: add amd microcode entries to grub config
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 1eae227f858fadfd463e84c7a63e73d024f6fb54..533c0e524807ec452175fbdafcedfc05e1c28c83 100644 (file)
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic xen_domu geode 64
-MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
+SUBTARGETS:=generic legacy geode 64
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-DEFAULT_PACKAGES += partx-utils
-
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \