Add support for creating VMware vmdk images #1317
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 771fd191f9b001457ec545bc4dabcf51cc60c89f..60f09a9d865c3376a3e1631d248f23506fad4eab 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext2 vdi vmdk
+SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.25.19
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))