move leds modules back to target modules.mk
[openwrt/openwrt.git] / target / linux / x86 / modules.mk
index 7826dc8acd55b5262b6edc1723052ada3334e65c..70a64ffdb4fa05c583d7945f8dfd18026c9c3f23 100644 (file)
@@ -280,3 +280,35 @@ define KernelPackage/i2c-scx200-acb/description
 endef
 
 $(eval $(call KernelPackage,i2c-scx200-acb))
+
+
+define KernelPackage/leds-wrap
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
+define KernelPackage/leds-net48xx
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Soekris Net48xx LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_NET48XX
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+endef
+
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net48xx))