x86: add amd microcode entries to grub config
[openwrt/openwrt.git] / target / linux / x86 / modules.mk
index 3abe01742baa8795306bff9bfa36adf5aede7cb8..87733c2850219f7319129a271dd631f4fa6b3553 100644 (file)
@@ -1,22 +1,36 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
 #
 # This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
 #
 
-define KernelPackage/rdc321x-wdt
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=RDC321x watchdog
-  DEPENDS:=@TARGET_x86_rdc
-  KCONFIG:=CONFIG_RDC321X_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+define KernelPackage/sound-cs5535audio
+  TITLE:=CS5535/CS5536 Audio Controller
+  DEPENDS:=@TARGET_x86_geode +kmod-ac97
+  KCONFIG:=CONFIG_SND_CS5535AUDIO
+  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
+  AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ Support for the integrated AC97 sound device on motherboards
+ with AMD CS5535/CS5536 chipsets.
 endef
 
-define KernelPackage/rdc321x-wdt/description
-  RDC-321x watchdog driver
+$(eval $(call KernelPackage,sound-cs5535audio))
+
+define KernelPackage/sp5100_tco
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=SP5100 Watchdog Support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_SP5100_TCO
+  FILES:=$(LINUX_DIR)/drivers/watchdog/sp5100_tco.ko
+  AUTOLOAD:=$(call AutoLoad,50,sp5100_tco,1)
 endef
 
-$(eval $(call KernelPackage,rdc321x-wdt))
+define KernelPackage/sp5100_tco/description
+ Kernel module for the SP5100_TCO hardware watchdog.
+endef
 
+$(eval $(call KernelPackage,sp5100_tco))