ath79: enable LNA for all ar9344 TPLink CPE devices
[openwrt/openwrt.git] / target / linux / zynq / Makefile
index 6c0ca921d5e1331263daf12e4abf86434df2d8e6..3119187c37c8b471782d2598d336edd7a01c5f1e 100644 (file)
@@ -9,10 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=zynq
 BOARDNAME:=Xilinx Zynq 7000 SoCs
-FEATURES:=fpu gpio rtc usb usbgadget ramdisk targz
+FEATURES:=fpu gpio rtc usb usbgadget boot-part rootfs-part squashfs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=neon
-MAINTAINER:=Jason Wu <jason.wu.misc@gmail.com>
 
 # future support SUBTARGETS: for both zynq and zynqmp
 
@@ -20,12 +19,13 @@ define Target/Description
        Build firmware image for Zynq 7000 SoC devices.
 endef
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image dtbs
 
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs \
+       kmod-usb-storage kmod-fs-msdos
 
 $(eval $(call BuildTarget))