treewide: remove redundant KERNEL_PREFIX definitions
[openwrt/openwrt.git] / target / linux / zynq / image / Makefile
index 39305a6d5435d0c1e725d235fc79fe937812fe61..0931871624e96db2d066c0fc911de89f1a960f69 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
@@ -31,9 +29,8 @@ endef
 
 define Device/Default
        PROFILES := Default
+       DEVICE_DTS := $(lastword $(subst _, ,$(1)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
-       KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
-       KERNEL_PREFIX := $$(IMAGE_PREFIX)
        KERNEL_LOADADDR := 0x8000
        IMAGES := sdcard.img.gz
        IMAGE/sdcard.img.gz := zynq-sdcard | gzip
@@ -53,7 +50,6 @@ define Device/avnet_zynq-zed
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Avnet
        DEVICE_MODEL := ZedBoard
-       DEVICE_DTS := zynq-zed
 endef
 TARGET_DEVICES += avnet_zynq-zed
 
@@ -61,7 +57,6 @@ define Device/digilent_zynq-zybo
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Digilent
        DEVICE_MODEL := Zybo
-       DEVICE_DTS := zynq-zybo
 endef
 TARGET_DEVICES += digilent_zynq-zybo
 
@@ -69,7 +64,6 @@ define Device/digilent_zynq-zybo-z7
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Digilent
        DEVICE_MODEL := Zybo Z7
-       DEVICE_DTS := zynq-zybo-z7
 endef
 TARGET_DEVICES += digilent_zynq-zybo-z7
 
@@ -77,7 +71,6 @@ define Device/xlnx_zynq-zc702
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Xilinx
        DEVICE_MODEL := ZC702
-       DEVICE_DTS := zynq-zc702
        DEVICE_PACKAGES:=kmod-can kmod-can-xilinx-can
 endef
 TARGET_DEVICES += xlnx_zynq-zc702