kernel: move kmod-i2c-bcm-iproc to I2C menu
[openwrt/openwrt.git] / toolchain / gdb / Makefile
index 97d88d65a60de92bab5db3e36a273598be125204..3452ac4dc7e9cb19063f8effd3cd5d671a410819 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2016 OpenWrt.org
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,24 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-
-ifeq ($(CONFIG_arc),y)
-PKG_VERSION:=arc-2016.03-gdb
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03-gdb
-PKG_MD5SUM:=775caaf6385c16f20b6f53c0a2b95f79
-GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
-else
-PKG_VERSION:=7.11
+PKG_VERSION:=8.3.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=b5c784685e1cde65ba135feea86b6d75
+PKG_HASH:=1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4
 GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
-endif
-
-PATCH_DIR:=./patches/$(PKG_VERSION)
 
 HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
 
@@ -42,7 +31,7 @@ HOST_CONFIGURE_ARGS = \
        --target=$(REAL_GNU_TARGET_NAME) \
        --disable-werror \
        --without-uiout \
-       --disable-tui --disable-gdbtk --without-x \
+       --enable-tui --disable-gdbtk --without-x \
        --without-included-gettext \
        --enable-threads \
        --with-expat \