ath9k: drop obsolete patch
[openwrt/openwrt.git] / tools / automake / Makefile
index c30a9900e613e5f527ff29f250b1c5c7b67c5faf..14585f8888b1a2eac3f38dd95b0c88d29a7c1194 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,25 +7,39 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
-PKG_VERSION:=1.11.1
+PKG_VERSION:=1.15
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=c2972c4d9b3e29c03d5f2af86249876f
+PKG_HASH:=9908c75aabd49d13661d6dcb1bc382252d22cc77bf733a2d55e87f2aa2db8636
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
-HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+HOST_CONFIGURE_ARGS += \
+       --datarootdir=$(STAGING_DIR_HOST)/share \
+       --disable-silent-rules
+
+HOST_CONFIGURE_VARS += \
+       PERL="/usr/bin/env perl" \
+       am_cv_prog_PERL_ithreads=no
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+       $(call Host/Configure/Default)
+endef
 
 define Host/Install
+       # remove old automake resources to avoid version conflicts
+       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
-       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
 endef
 
 define Host/Clean