netifd: update to the latest version
[openwrt/openwrt.git] / tools / libressl / Makefile
index 4c7e8a7b6ecc1c57cd004869a3d4dd3b3ad29328..29fae1dfb65c0d8d988656c13b3853787de0b930 100644 (file)
@@ -8,20 +8,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=2.7.2
-PKG_HASH:=917a8779c342177ff3751a2bf955d0262d1d8916a4b408930c45cef326700995
+PKG_VERSION:=3.3.4
+PKG_HASH:=bcce767a3fed252bfd1210f8a7e3505a2b54d3008f66e43d9b95e3f30c072931
 PKG_RELEASE:=1
 
+PKG_CPE_ID:=cpe:/a:openbsd:libressl
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
-       http://ftp.openbsd.org/pub/OpenBSD/LibreSSL
+       https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += --disable-shared
-HOST_CFLAGS += $(FPIC)
+HOSTCC := $(HOSTCC_NOCACHE)
+HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+HOST_CFLAGS += $(HOST_FPIC)
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
 
 $(eval $(call HostBuild))