netfilter: drop proprietary xt_id match
[openwrt/openwrt.git] / tools / mkimage / patches / 040-include_order.patch
index 5a9d15eb765442ddd38905efbd5c6165ad2cb743..3b9ecc6bd3e4889573175ceb83914fb5abb4579b 100644 (file)
@@ -1,14 +1,11 @@
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
- # Use native tools and options
- # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+@@ -194,7 +194,7 @@ endif # !LOGO_BMP
+ # Define _GNU_SOURCE to obtain the getline prototype from stdio.h
  #
--HOSTCPPFLAGS =        -idirafter $(SRCTREE)/include \
-+HOSTCPPFLAGS =        -I $(SRCTREE)/include \
-               -idirafter $(OBJTREE)/include2 \
--              -idirafter $(OBJTREE)/include \
-+              -I $(OBJTREE)/include \
-               -I $(SRCTREE)/lib/libfdt \
-               -I $(SRCTREE)/tools \
+ HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
+-              $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
++              -I$(srctree)/include \
+               -I$(srctree)/lib/libfdt \
+               -I$(srctree)/tools \
                -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \