ar71xx: create the temporary directory before building initramfs images
authorGabor Juhos <juhosg@openwrt.org>
Thu, 26 Jan 2012 21:28:34 +0000 (21:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 26 Jan 2012 21:28:34 +0000 (21:28 +0000)
Thanks to Florian for reporting.

SVN-Revision: 29915

target/linux/ar71xx/image/Makefile

index 4e538b8b70399dd211145cd73847d655343efb30..1905c731033832b876879330b74a5d1b3e217331 100644 (file)
@@ -128,8 +128,8 @@ define Image/BuildKernel
        dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
        $(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
        $(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
-       $(call Image/Build/Initramfs)
        -mkdir -p $(KDIR_TMP)
+       $(call Image/Build/Initramfs)
 endef
 
 define Image/Build/WRT400N