base-files: fwtool: make compat_version backward compatible
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 9 Jul 2020 17:46:44 +0000 (19:46 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 31 Jul 2020 09:40:15 +0000 (11:40 +0200)
So far, the compatibility mechanism only works if both device and
image are already updated to the new routines. This patch extends
the sysupgrade metadata and fwtool_check_image() to account for
"older" images as well:

The basic mechanism for older devices to check for image compatibility
is the supported_devices entry. This can be exploited by putting
a custom message into this variable of the metadata, so older FW
will produce a mismatch and print the message as it thinks it's the
list of supported devices. So, we have two cases:

device 1.0, image 1.0:
  The metadata will just contain supported_devices as before.

device 1.0, image 1.1:
  The metadata will contain:

  "new_supported_devices":["device_string1", "device_string2", ...],
  "supported_devices":["Image version 1.1 incompatible to device: ..."]

  If the device is "legacy", i.e. does not have the updated fwtool.sh,
  it will just fail with image check and print the content of
  supported_devices. If DEVICE_COMPAT_MESSAGE is set, this will be
  printed on old devices as well through the same mechanism. Otherwise
  a generic "Please check documentation ..." is appended.

  Upgrade can still be performed with -F like when
  SUPPORTED_DEVICES has been removed to prevent bricking.

  If the device has updated fwtool.sh (but is 1.0), it will just use
  the new_supported_devices instead, and work as intended (flashing
  with -n will work, flashing without will print the appropriate
  warning).

This mechanism should provide a fair tradeoff between simplicity
and functionality.

Since we touched a lot of fields in metadata, this also bumps
metadata_version to 1.1.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
include/image-commands.mk
package/base-files/files/lib/upgrade/fwtool.sh

index 9da712e73360708bcdf6c0d5d57c38cf66ac2e54..7a370034c8fb0a4c3173fd6b1f5c92e9addfec99 100644 (file)
@@ -390,10 +390,13 @@ json_quote=$(subst ','\'',$(subst ",\",$(1)))
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
 metadata_json = \
        '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
-               "metadata_version": "1.0", \
+               "metadata_version": "1.1", \
                "compat_version": "$(call json_quote,$(compat_version))", \
                $(if $(DEVICE_COMPAT_MESSAGE),"compat_message": "$(call json_quote,$(DEVICE_COMPAT_MESSAGE))"$(comma)) \
-               "supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))], \
+               $(if $(filter-out 1.0,$(compat_version)),"new_supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma)) \
+               $(if $(filter-out 1.0,$(compat_version)),"supported_devices": \
+                       ["$(call json_quote,Image version $(compat_version) incompatible to device: $(if $(DEVICE_COMPAT_MESSAGE),$(DEVICE_COMPAT_MESSAGE),Please check documentation ...))"]$(comma)) \
+               $(if $(filter 1.0,$(compat_version)),"supported_devices":[$(call metadata_devices,$(SUPPORTED_DEVICES))]$(comma)) \
                "version": { \
                        "dist": "$(call json_quote,$(VERSION_DIST))", \
                        "version": "$(call json_quote,$(VERSION_NUMBER))", \
index e8277f6fccc8fdc3c93aa770ffe0b153f11b22c0..3a74c72bba74d8c282eecd6b11cad52e52dfe899 100644 (file)
@@ -51,7 +51,12 @@ fwtool_check_image() {
        json_get_var compatmessage compat_message
        [ -n "$imagecompat" ] || imagecompat="1.0"
 
-       json_select supported_devices || return 1
+       # select correct supported list based on compat_version
+       # (using this ensures that compatibility check works for devices
+       #  not knowing about compat-version)
+       local supported=supported_devices
+       [ "$imagecompat" != "1.0" ] && supported=new_supported_devices
+       json_select $supported || return 1
 
        json_get_keys dev_keys
        for k in $dev_keys; do