kernel: fix crypto-hw-talitos dependencies
authorGabor Juhos <juhosg@openwrt.org>
Sat, 20 Jul 2013 20:44:40 +0000 (20:44 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 20 Jul 2013 20:44:40 +0000 (20:44 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37485

package/kernel/linux/modules/crypto.mk

index ade5f9493b6e755d77f851dae7418aa3f9d5a709..6a636fcb7fbd56d3db6ed9f5c989bcea2913e362 100644 (file)
@@ -121,7 +121,7 @@ $(eval $(call KernelPackage,crypto-iv))
 
 define KernelPackage/crypto-hw-talitos
   TITLE:=Freescale integrated security engine (SEC) driver
-  DEPENDS:=+kmod-crypto-aes
+  DEPENDS:=+kmod-crypto-aes +kmod-crypto-manager +kmod-crypto-hash +kmod-random-core
   KCONFIG:= \
        CONFIG_CRYPTO_DEV_TALITOS
   FILES:= \