add --without-x to dsniff compile and add mostlyclean target
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2005 20:18:17 +0000 (20:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2005 20:18:17 +0000 (20:18 +0000)
SVN-Revision: 1222

openwrt/package/dsniff/Makefile

index 6d6b6064ba8365d5d468b48995d179472a0bddb6..3355eb88d9bdc0360ae67c028fbbd5a2a5bee6ab 100644 (file)
@@ -43,6 +43,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                  --sbindir=/usr/sbin \
                  --sysconfdir=/etc \
                  --without-db \
+                 --without-x \
                  --with-gdbm="$(STAGING_DIR)/usr" \
                  --with-libnids="$(STAGING_DIR)/usr" \
                  --with-libpcap="$(STAGING_DIR)/usr" \
@@ -69,3 +70,7 @@ $(IPKG_DSNIFF):
        cp -fpR  $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_DSNIFF)/usr/lib
        $(RSTRIP) $(IDIR_DSNIFF)
        $(IPKG_BUILD) $(IDIR_DSNIFF) $(PACKAGE_DIR)
+
+mostlyclean:
+       make -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built