ramips: fix booting on ZyXEL NBG-419N v2
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 23 May 2022 15:50:19 +0000 (17:50 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Mon, 20 Jun 2022 09:10:24 +0000 (11:10 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of other devices from 'ramips' target.

Fixes: #9842
Fixes: #8964
Reported-by: Juergen Hench <jurgen.hench@gmail.com>
Tested-by: Juergen Hench <jurgen.hench@gmail.com>
Signed-off-by: Demetris Ierokipides <ierokipides.dem@gmail.com>
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
(cherry picked from commit fd72e595c2b2a46bab8cbc7e9415fbfeae7b5b0d)

target/linux/ramips/image/rt305x.mk

index 4edc2eb3c4b7b5ade5f301467f8dbcdf569a3945..9b498fa5ab1189217a792b70a97cba714d57cad0 100644 (file)
@@ -1237,6 +1237,7 @@ endef
 TARGET_DEVICES += zyxel_nbg-419n
 
 define Device/zyxel_nbg-419n-v2
+  $(Device/uimage-lzma-loader)
   SOC := rt3352
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL