ddns-scripts: Add v2 API for mythic-beasts.com provider 20621/head
authorJim Hague <jim.hague@acm.org>
Thu, 9 Mar 2023 13:06:06 +0000 (13:06 +0000)
committerJim Hague <jim.hague@acm.org>
Thu, 9 Mar 2023 15:39:58 +0000 (15:39 +0000)
Use USERNAME as the key, PASSWORD as the secret.

Signed-off-by: Jim Hague <jim.hague@acm.org>
net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/share/ddns/default/mythic-beasts.com-v2.json [new file with mode: 0644]
net/ddns-scripts/files/usr/share/ddns/list

index 1f35ed7d82a3129b9272e51e945328d6f9f301eb..19bebeef045431b144a382dbc01579e73262b82c 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.8.2
-PKG_RELEASE:=36
+PKG_RELEASE:=37
 
 PKG_LICENSE:=GPL-2.0
 
diff --git a/net/ddns-scripts/files/usr/share/ddns/default/mythic-beasts.com-v2.json b/net/ddns-scripts/files/usr/share/ddns/default/mythic-beasts.com-v2.json
new file mode 100644 (file)
index 0000000..e246223
--- /dev/null
@@ -0,0 +1,9 @@
+{
+        "name": "mythic-beasts.com (API v2)",
+        "ipv4": {
+                "url": "https://[USERNAME]:[PASSWORD]@ipv4.api.mythic-beasts.com/dns/v2/dynamic/[DOMAIN]"
+        },
+        "ipv6": {
+                "url": "https://[USERNAME]:[PASSWORD]@ipv6.api.mythic-beasts.com/dns/v2/dynamic/[DOMAIN]"
+        }
+}
index c55115c1593d1a5ce7bf46dac579c0594b04df7d..86902313a0648a9c64ae57eb28c5fb00924926c7 100644 (file)
@@ -41,6 +41,7 @@ moniker.com
 mydns.jp
 myonlineportal.net
 mythic-beasts.com
+mythic-beasts.com-v2
 namecheap.com
 njal.la
 no-ip.pl