udp-broadcast-relay-redux-openwrt: add cgroupsns to jail
authorBackSlasher <nitz.raz@gmail.com>
Thu, 9 Mar 2023 08:13:39 +0000 (10:13 +0200)
committerTianling Shen <cnsztl@gmail.com>
Thu, 9 Mar 2023 10:25:03 +0000 (18:25 +0800)
Added `cgroupsns` to jail, otherwise you get this failure:
```
Mon Mar  6 14:46:05 2023 user.err : jail: Not using namespaces, capabilities or seccomp !!!
```
Error is here, seems to indicate that we're running a jail without using any capability.
https://lxr.openwrt.org/source/procd/jail/jail.c#L2847

Decided to use minimal effort approach

Signed-off-by: BackSlasher <nitz.raz@gmail.com>
net/udp-broadcast-relay-redux-openwrt/Makefile
net/udp-broadcast-relay-redux-openwrt/files/udp-broadcast-relay-redux.init

index f3854fb809ffeaef5e1dacd44bd8f985bd166140..8f120d944147a9c6ca451ac43857019c3588b375 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udp-broadcast-relay-redux
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0
 
 PKG_SOURCE_PROTO:=git
index aa35f554622874e09a61166374f596aa426a3239..6694215885ee46f4fa646feec8b0278b1384de6f 100644 (file)
@@ -58,7 +58,7 @@ udp_broadcast_relay_redux_instance() {
         procd_append_param command "-t" "$dest_override"
     fi
 
-    procd_add_jail ubr-${PIDCOUNT}
+    procd_add_jail ubr-${PIDCOUNT} cgroupsns
     procd_close_instance
 }