wireguard: don't build on Linux 5.10
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Mon, 22 Feb 2021 00:03:12 +0000 (16:03 -0800)
committerDavid Bauer <mail@david-bauer.net>
Tue, 23 Feb 2021 19:13:30 +0000 (20:13 +0100)
There are efforts underway to bring wireguard in-tree for Linux 5.4 and
to have a common build infrastructure for both 5.4 and 5.10 for
kmod-wireguard[0]. Until then, restrict kmod-wireguard to build only on
Linux 5.4, because the wireguard-compat package will not build on Linux
5.10.

[0]: https://github.com/openwrt/openwrt/pull/3885

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
package/network/services/wireguard/Makefile

index 91bdb0d7a77990289f4a151fd81315de88883fbb..5a4d7ee871c9777f7043086c170df7c46d35c82b 100644 (file)
@@ -50,7 +50,7 @@ endef
 define Package/wireguard
   $(call Package/wireguard/Default)
   TITLE:=WireGuard meta-package
-  DEPENDS:=+wireguard-tools +kmod-wireguard
+  DEPENDS:=+wireguard-tools +kmod-wireguard @LINUX_5_4
 endef
 
 include $(INCLUDE_DIR)/kernel-defaults.mk
@@ -73,7 +73,7 @@ define KernelPackage/wireguard
   CATEGORY:=Kernel modules
   SUBMENU:=Network Support
   TITLE:=WireGuard kernel module
-  DEPENDS:=+IPV6:kmod-udptunnel6 +kmod-udptunnel4
+  DEPENDS:=+IPV6:kmod-udptunnel6 +kmod-udptunnel4 @LINUX_5_4
   FILES:= $(PKG_BUILD_DIR)/src/wireguard.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoProbe,wireguard)
 endef