ar71xx: merge generic machine code into setup.c
authorGabor Juhos <juhosg@openwrt.org>
Mon, 25 Jan 2010 14:24:48 +0000 (14:24 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 25 Jan 2010 14:24:48 +0000 (14:24 +0000)
SVN-Revision: 19325

target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-generic.c [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/setup.c

index 878b6cd91027783dffe3127c176743c2c5df7d76..89146ecd11c889dc5fa42c2443eb6ffb9c145d9f 100644 (file)
@@ -19,7 +19,6 @@ CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_DIR_600_A1=y
 CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
-CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
@@ -184,9 +183,9 @@ CONFIG_PHYLIB=y
 # CONFIG_PNX8550_STB810 is not set
 # CONFIG_PROBE_INITRD_HEADER is not set
 CONFIG_RTL8306_PHY=y
-CONFIG_RTL8366_SMI=y
 CONFIG_RTL8366S_PHY=y
-# CONFIG_RTL8366S_PHY_DEBUG_FS is not set
+CONFIG_RTL8366S_PHY_DEBUG_FS=y
+CONFIG_RTL8366_SMI=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
 # CONFIG_SERIAL_8250_EXTENDED is not set
index 95bbc55a890b67e9b1f67707ddc4f3c57d1324cd..9cdfa01879ef0990ae88495d7eff25c921d69082 100644 (file)
@@ -21,7 +21,6 @@ CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_DIR_600_A1=y
 CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
-CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
index 2d83f96dfdc44033d3ec98700783ad8a14c7d2c5..002e4a93573d7c5c9ce3d08afc0c13008eee803e 100644 (file)
@@ -21,7 +21,6 @@ CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_DIR_600_A1=y
 CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
-CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
index 29c5590c8d8a34a1b7b050eb362fd316e7890f5f..50ae98faeabf4e539d982f87498ba3b72b3d5123 100644 (file)
@@ -76,10 +76,6 @@ config AR71XX_MACH_WZR_HP_G300NH
        select AR71XX_DEV_USB
        default y
 
-config AR71XX_MACH_GENERIC
-       bool "Generic AR71xx based machine support"
-       default y
-
 config AR71XX_MACH_WP543
        bool "Compex WP543/WPJ543 board support"
        select MYLOADER
index bf13b8d6e02e17addb6fec8d5f2c8b2331d5353c..13b5c41fe180d002706bd1b54467fe42c3604e03 100644 (file)
@@ -31,7 +31,6 @@ obj-$(CONFIG_AR71XX_MACH_AW_NR580)    += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_DIR_600_A1)   += mach-dir-600-a1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_615_C1)   += mach-dir-615-c1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_825_B1)   += mach-dir-825-b1.o
-obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
 obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-generic.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-generic.c
deleted file mode 100644 (file)
index 8dfa640..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-/*
- *  Generic AR71xx machine support
- *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
- *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/init.h>
-
-#include <asm/mach-ar71xx/ar71xx.h>
-#include "machtype.h"
-
-static void __init ar71xx_generic_init(void)
-{
-       /* Nothing to do */
-}
-
-MIPS_MACHINE(AR71XX_MACH_GENERIC, "Generic", "Generic AR71xx board",
-            ar71xx_generic_init);
index f23592223aef68045fc1aa06cddc3955a7ef04bc..1d9feda67b0e046056bba68a061ca7ffedba85ac 100644 (file)
@@ -288,3 +288,11 @@ static int __init ar71xx_machine_setup(void)
 }
 
 arch_initcall(ar71xx_machine_setup);
+
+static void __init ar71xx_generic_init(void)
+{
+       /* Nothing to do */
+}
+
+MIPS_MACHINE(AR71XX_MACH_GENERIC, "Generic", "Generic AR71xx board",
+            ar71xx_generic_init);