busybox: make username consistent
authorDaniel Golle <daniel@makrotopia.org>
Sun, 25 Oct 2020 17:24:03 +0000 (17:24 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 25 Oct 2020 17:26:30 +0000 (17:26 +0000)
ntpd in packages feed had already a user 'ntp' with UID 123 declared.
Rename the username of busybox-ntpd to be 'ntp' instead of 'ntpd' so
it doesn't clash.

Reported-by: Etienne Champetier <champetier.etienne@gmail.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/services/dnsmasq/files/dnsmasqsec_hotplug_acl.json
package/utils/busybox/Makefile
package/utils/busybox/files/sysntpd

index a5eac3943de80f3b6390ea46abf5ebf98cf5d29a..861ecbe034b4dbf731fbe2fd645ece5bcfdcfdca 100644 (file)
@@ -1,5 +1,5 @@
 {
-       "user": "ntpd",
+       "user": "ntp",
        "access": {
                "service": {
                        "methods": [ "signal" ]
index 6d9a0088e577364ed068da963fb0b12b213eb5d3..25db4ff387cfc64e7e79dde37df6f7ab63df9120 100644 (file)
@@ -50,7 +50,7 @@ define Package/busybox/Default
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
   DEPENDS:=+BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
-  USERID:=ntpd=123:ntpd=123
+  USERID:=ntp=123:ntp=123
 endef
 
 define Package/busybox
index cbc760a48ede88a74fa4e9901a357be56ceb4249..db5fc6c034fe8c371955ad56382dd12e5f5ab8c5 100755 (executable)
@@ -58,8 +58,8 @@ start_ntpd_instance() {
        [ -x /sbin/ujail ] && {
                procd_add_jail ntpd
                procd_set_param capabilities /etc/capabilities/ntpd.json
-               procd_set_param user ntpd
-               procd_set_param group ntpd
+               procd_set_param user ntp
+               procd_set_param group ntp
                procd_set_param no_new_privs 1
        }
        procd_close_instance