kernel: bump 4.9 to 4.9.146
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 18 Dec 2018 13:12:21 +0000 (14:12 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 18 Dec 2018 14:12:06 +0000 (15:12 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch

index 30e1edf75eb7e8dde77df16ac79a5e068c316bc0..414a5bcee8b6237b85812b9ea17e2e911cf926a7 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .145
 LINUX_VERSION-4.14 = .88
+LINUX_VERSION-4.9 = .146
 
-LINUX_KERNEL_HASH-4.9.145 = 6901ca37e8c305a2f26c598952338b4dc2481ca5a9d0bf71e2b71730a5b5bc5e
 LINUX_KERNEL_HASH-4.14.88 = b0f0b8c76708eab6caf3009702e531d40a243b152922ee1f9a441316f226f52d
+LINUX_KERNEL_HASH-4.9.146 = 58195a8be3085d117c83a2ed1caa3b46ea7c1614c75f951b9f13f7adb03f8e59
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 4a3f355b4d8ef2c9b069a6ec37eff7fd59caa8a3..0a5b9ead9dc4bb63825fdcbddba36806a848292c 100644 (file)
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
-@@ -3542,8 +3542,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3546,8 +3546,6 @@ void __tcp_send_ack(struct sock *sk, u32
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
index 4124bab4adf7b85b48b307f6bc43f09dc56dad5b..9c23279188261d1c78c8db0ace2b295d512c631a 100644 (file)
@@ -1713,7 +1713,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ret = phydrv->resume(phydev);
  
        if (ret)
-@@ -1723,7 +1723,7 @@ static int phy_remove(struct device *dev
+@@ -1720,7 +1720,7 @@ static int phy_remove(struct device *dev
        phydev->state = PHY_DOWN;
        mutex_unlock(&phydev->lock);