update everything to the latest version
authorMike Baker <mbm@openwrt.org>
Mon, 9 Aug 2004 04:09:46 +0000 (04:09 +0000)
committerMike Baker <mbm@openwrt.org>
Mon, 9 Aug 2004 04:09:46 +0000 (04:09 +0000)
SVN-Revision: 132

obsolete-buildroot/Makefile
obsolete-buildroot/make/busybox.mk
obsolete-buildroot/make/dnsmasq.mk
obsolete-buildroot/make/dropbear_sshd.mk
obsolete-buildroot/make/uclibc.mk
obsolete-buildroot/sources/openwrt/kernel/linux.config

index 304c802b85cf083c90c5ac67c2723053470af986..3f0164afd40421406be4c9ff64defd5fc8c8b1d1 100644 (file)
@@ -28,7 +28,7 @@
 #
 #############################################################
 
-SNAPSHOT:=20040705
+SNAPSHOT:=20040807
 
 ARCH:=mipsel
 USE_UCLIBC_SNAPSHOT:=$(SNAPSHOT)
index a0e816716713cfed22ceb613021396fb122ab02f..baeb952667b2230677b2da687c129051a982d872 100644 (file)
@@ -8,11 +8,7 @@ ifneq ($(strip $(USE_BUSYBOX_SNAPSHOT)),)
 # Be aware that this changes daily....
 BUSYBOX_DIR:=$(BUILD_DIR)/busybox
 BUSYBOX_SOURCE:=busybox-$(strip $(USE_BUSYBOX_SNAPSHOT)).tar.bz2
-#BUSYBOX_SITE:=http://www.busybox.net/downloads/snapshots
-#
-# TEMPORARY HACK!
-#
-BUSYBOX_SITE:=http://openwrt.ksilebo.net/downloads
+BUSYBOX_SITE:=http://www.busybox.net/downloads/snapshots
 else
 BUSYBOX_DIR:=$(BUILD_DIR)/busybox-1.00-pre8
 BUSYBOX_SOURCE:=busybox-1.00-pre8.tar.bz2
index 3bd9034c8bccf58fd3d8c32dd126ce1e8c9dd3f6..b818aad41e9a5c9c2945e79c21e06d9159a7abbf 100644 (file)
@@ -6,8 +6,8 @@
 
 DNSMASQ_SITE=http://thekelleys.org.uk/dnsmasq
 ifeq ($(filter $(TARGETS),dnsmasq1),)
-DNSMASQ_SOURCE=dnsmasq-2.8.tar.gz
-DNSMASQ_DIR=$(BUILD_DIR)/dnsmasq-2.8
+DNSMASQ_SOURCE=dnsmasq-2.11.tar.gz
+DNSMASQ_DIR=$(BUILD_DIR)/dnsmasq-2.11
 DNSMASQ_VER=dnsmasq2
 else
 DNSMASQ_SOURCE=dnsmasq-1.18.tar.gz
index d694508f92a0730744b376ba78b65aa2cf2019b1..04f6f066dc620bfbefb362ed33a6e6555bacaca9 100644 (file)
@@ -3,9 +3,9 @@
 # dropbear_sshd
 #
 #############################################################
-DROPBEAR_SSHD_SOURCE:=dropbear-0.41.tar.bz2
+DROPBEAR_SSHD_SOURCE:=dropbear-0.43.tar.bz2
 DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/releases/
-DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.41
+DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.43
 DROPBEAR_SSHD_CAT:=bzcat
 DROPBEAR_SSHD_BINARY:=dropbearmulti
 DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
@@ -18,8 +18,6 @@ dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
 
 $(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
        $(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
-       $(SOURCE_DIR)/patch-kernel.sh $(DROPBEAR_SSHD_DIR) $(SOURCE_DIR) dropbear-*.patch
-       $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_SSHD_DIR)/options.h
        touch $(DROPBEAR_SSHD_DIR)/.unpacked
 
 $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
@@ -43,24 +41,35 @@ $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                --with-shared \
+               \
+               --disable-zlib \
+               --disable-syslog \
+               --disable-lastlog \
+               --disable-utmp \
+               --disable-utmpx \
+               --disable-wtmp \
+               --disable-wtmpx \
+               --disable-loginfunc \
+               --disable-pututline \
+               --disable-pututxline \
        );
        touch  $(DROPBEAR_SSHD_DIR)/.configured
 
 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
        $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
-               -C $(DROPBEAR_SSHD_DIR) dropbearmulti
+               -C $(DROPBEAR_SSHD_DIR) strip
 
 $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
        #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
        #       LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
        #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
        #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
-       install -d -m 755 $(TARGET_DIR)/usr/sbin
-       install -d -m 755 $(TARGET_DIR)/usr/bin
-       install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
-               $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
-       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
-       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
+       install -d -m 755 $(TARGET_DIR)/usr/sbin
+       install -d -m 755 $(TARGET_DIR)/usr/bin
+       install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
+       #       $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
 
 dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
 
index 86502982a2cdc57ea23f87882cb09b188c2faa68..44bff70a92a27d373b2d93f00f685ad0ba7f5741 100644 (file)
@@ -7,11 +7,7 @@ ifneq ($(strip $(USE_UCLIBC_SNAPSHOT)),)
 # Be aware that this changes daily....
 UCLIBC_DIR:=$(BUILD_DIR)/uClibc
 UCLIBC_SOURCE:=uClibc-$(strip $(USE_UCLIBC_SNAPSHOT)).tar.bz2
-#UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
-#
-#  TEMPORARY HACK!
-#
-UCLIBC_SITE:=http://openwrt.ksilebo.net/downloads
+UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
 else
 UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.26
 UCLIBC_SOURCE:=uClibc-0.9.26.tar.bz2
@@ -51,7 +47,7 @@ endif
 ifeq ($(strip $(USE_UCLIBC_LDSO_0_9_24)),true)
        $(SOURCE_DIR)/patch-kernel.sh $(UCLIBC_DIR) $(SOURCE_DIR) uClibc-ldso-0.9.24.patch
 endif
-       $(SOURCE_DIR)/patch-kernel.sh $(UCLIBC_DIR) $(SOURCE_DIR) uClibc-ftruncate.patch
+       $(SOURCE_DIR)/patch-kernel.sh $(UCLIBC_DIR) $(SOURCE_DIR) uClibc-sigaction.patch
        touch $(UCLIBC_DIR)/.unpacked
 
 $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked $(LINUX_DIR)/.configured
index 07e044ec00757d02ab04875978ff64a6fe91b316..caaa413746c28e950cab7cfa67336fbcf55156bd 100644 (file)
@@ -129,7 +129,7 @@ CONFIG_HOTPLUG=y
 # CONFIG_HOTPLUG_PCI_COMPAQ is not set
 # CONFIG_HOTPLUG_PCI_COMPAQ_NVRAM is not set
 # CONFIG_HOTPLUG_PCI_ACPI is not set
-# CONFIG_SYSVIPC is not set
+CONFIG_SYSVIPC=y
 # CONFIG_BSD_PROCESS_ACCT is not set
 CONFIG_SYSCTL=y
 # CONFIG_PRINT_SYSCALLS is not set
@@ -325,7 +325,7 @@ CONFIG_IP_NF_MATCH_DSTLIMIT=m
 CONFIG_IP_NF_MATCH_MAC=m
 CONFIG_IP_NF_MATCH_PKTTYPE=m
 CONFIG_IP_NF_MATCH_MARK=y
-CONFIG_IP_NF_MATCH_MULTIPORT=m
+CONFIG_IP_NF_MATCH_MULTIPORT=y
 CONFIG_IP_NF_MATCH_TOS=m
 CONFIG_IP_NF_MATCH_CONDITION=m
 # CONFIG_IP_NF_MATCH_RANDOM is not set