fix and make usable kmod-pcmcia-rsrc
authorFlorian Fainelli <florian@openwrt.org>
Tue, 21 Jun 2011 20:52:53 +0000 (20:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 21 Jun 2011 20:52:53 +0000 (20:52 +0000)
This module is also needed for e.g: kmod-bcm63xx-pcmcia

SVN-Revision: 27253

package/kernel/modules/pcmcia.mk
target/linux/brcm63xx/modules.mk

index 468a62f0a09e85ccad751523b2ceca7a3fcc15cb..e4df2aa395915b73a1f839c4051ccc5999a19127 100644 (file)
@@ -28,28 +28,37 @@ endef
 
 $(eval $(call KernelPackage,pcmcia-core))
 
-
-define KernelPackage/pcmcia-yenta
+define KernelPackage/pcmcia-rsrc
   SUBMENU:=$(PCMCIA_MENU)
-  TITLE:=yenta socket driver
+  TITLE:=PCMCIA resource support
   DEPENDS:=kmod-pcmcia-core
-  KCONFIG:= \
-       CONFIG_PCCARD_NONSTATIC \
-       CONFIG_YENTA
+  KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
 # For Linux 2.6.35+
 ifneq ($(wildcard $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko),)
-  FILES:= \
-       $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko \
-       $(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
-  AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
+  AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
 else
-  FILES:= \
-       $(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko \
-       $(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
-  AUTOLOAD:=$(call AutoLoad,41,rsrc_nonstatic yenta_socket)
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko \
+  AUTOLOAD:=$(call AutoLoad,26,rsrc_nonstatic)
 endif
 endef
 
+define KernelPackage/pcmcia-rsrc/description
+  Kernel support for PCMCIA resource allocation
+endef
+
+$(eval $(call KernelPackage,pcmcia-rsrc))
+
+
+define KernelPackage/pcmcia-yenta
+  SUBMENU:=$(PCMCIA_MENU)
+  TITLE:=yenta socket driver
+  DEPENDS:=kmod-pcmcia-rsrc
+  KCONFIG:=CONFIG_YENTA
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
+  AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
+endef
+
 $(eval $(call KernelPackage,pcmcia-yenta))
 
 
index 845fb644a76963784a284e89fe7b31bd1b47cd2c..e48d298bf0fc00d95aab8cceefd4a2809941d685 100644 (file)
@@ -24,7 +24,7 @@ $(eval $(call KernelPackage,bcm63xx-spi))
 define KernelPackage/pcmcia-bcm63xx
   SUBMENU:=$(PCMCIA_MENU)
   TITLE:=Broadcom BCM63xx PCMCIA support
-  DEPENDS:=@TARGET_brcm63xx kmod-pcmcia-core
+  DEPENDS:=@TARGET_brcm63xx +kmod-pcmcia-rsrc
   KCONFIG:=CONFIG_PCMCIA_BCM63XX
   FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.ko
   AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)