ath79: wnr1000v2: fix image header information
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Tue, 22 Oct 2019 13:26:12 +0000 (15:26 +0200)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 12:42:31 +0000 (13:42 +0100)
Factory image generated for Netgear WNR1000 v2 has incorrect device
and hardware ID information in header due to missing makefile
variables. This fix adds them to device section.

Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
target/linux/ath79/image/tiny-netgear.mk

index 0df19390bb5f29afd3a00f39ee35e735be049cea..d257ddd0ec0e446b28141fa090272a5e6a191f99 100644 (file)
@@ -33,6 +33,8 @@ define Device/netgear_wnr1000-v2
   DEVICE_MODEL := WNR1000
   DEVICE_VARIANT := v2
   NETGEAR_KERNEL_MAGIC := 0x31303031
+  NETGEAR_BOARD_ID := WNR1000V2
+  NETGEAR_HW_ID := 29763331+4+32
   IMAGE_SIZE := 3712k
   IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
   SUPPORTED_DEVICES += wnr1000-v2