brcm63xx: add DT support for F@ST2704V2
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:04 +0000 (00:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:04 +0000 (00:51 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43449

target/linux/brcm63xx/dts/fast2704v2.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/profiles/sagem.mk

diff --git a/target/linux/brcm63xx/dts/fast2704v2.dts b/target/linux/brcm63xx/dts/fast2704v2.dts
new file mode 100644 (file)
index 0000000..f001b77
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "Sagem F@ST2704V2";
+       compatible = "sagem,f@st2704v2", "brcm,bcm6328";
+};
index 21e3825fcaf8a2350626c5f25a88ec8413a7d388..14d07309f7e0d89f15ebfdb171424d9fb78b050f 100755 (executable)
@@ -220,9 +220,6 @@ define Image/Build
        # TP-Link 8900GB
        $(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
 
-       # Sagem F@ST2704V2
-       $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2-cfe)
-       $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
 
@@ -324,6 +321,8 @@ $(eval $(call ImageDTB,CFEDTB,A226M,a226m-fwb,DWV-S0,6358,A226M-FWB,--block-size
 $(eval $(call ImageDTB,CFEDTB,FAST2404,fast2404,F@ST2404,6348,F@ST2404))
 # Sagem F@ST2604
 $(eval $(call ImageDTB,CFEDTB,FAST2604,fast2604,F@ST2604,6348,F@ST2604))
+# Sagem F@ST2704V2
+$(eval $(call ImageDTB,CFEDTB,FAST2704V2,fast2704v2,F@ST2704V2,6328,F@ST2704V2))
 # T-Com Speedport W 303V Typ B
 $(eval $(call ImageDTB,SPW303VCFEDTB,SPW303V,spw303v,96358-502V,6358,SPW303V,--pad 4))
 # T-Com Speedport W 500V
index c647396c477e8c1be995dea2da487d46ce945ff7..a974aa34ceb44d6f0d40cd80b236b8283d70143b 100644 (file)
@@ -143,3 +143,11 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6338
        &board_96338gw,
+@@ -3576,6 +3693,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96328avng", .data = &board_96328avng, },
+       { .compatible = "comtrend,ar-5381u", .data = &board_AR5381u, },
+       { .compatible = "comtrend,ar-5387un", .data = &board_AR5387un, },
++      { .compatible = "sagem,f@st2704v2", .data = &board_FAST2704V2, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6338
+       { .compatible = "brcm,bcm96338gw", .data = &board_96338gw, },
index 17686d3b83c3ed970d4a11518682c7d8db4938d5..80ae8932f149ebf90b60a2cdae1bec6fc6c8e80a 100644 (file)
@@ -22,3 +22,13 @@ define Profile/FAST2604/Description
   Package set optimized for F@ST2604.
 endef
 $(eval $(call Profile,FAST2604))
+
+define Profile/FAST2704V2
+  NAME:=Sagem F@ST2704V2
+  PACKAGES:=kmod-b43 wpad-mini\
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/FAST2704V2/Description
+  Package set optimized for F@ST2704V2.
+endef
+$(eval $(call Profile,FAST2704V2))