firewall3: add support for shell script and iptables-restore style includes
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 22 Feb 2013 12:45:38 +0000 (12:45 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 22 Feb 2013 12:45:38 +0000 (12:45 +0000)
SVN-Revision: 35744

package/network/config/firewall3/Makefile
package/network/config/firewall3/files/firewall.hotplug

index 5282613d65920e68dc429d6f56957a258f97d791..f4a9b18e28a6388d608619c4912480416d9c486f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-02-21
+PKG_VERSION:=2013-02-22
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fe3ecee341da8542aa25b962dcb8bcc628fcdd1e
+PKG_SOURCE_VERSION:=83ff4b94b044086d80b1e189e5601274bd5b4852
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
index a173b130bfff8accaa5cb77e8a6270e20cb63e67..dbb98cdcd203fbbfa6dfa8c83aa904e13ec38b3d 100644 (file)
@@ -4,5 +4,5 @@
 
 fw3 -q network "$INTERFACE" >/dev/null || exit 0
 
-logger -t firewall "Restarting firewall due to ifup of $INTERFACE ($DEVICE)"
-fw3 -q restart
+logger -t firewall "Reloading firewall due to ifup of $INTERFACE ($DEVICE)"
+fw3 -q reload