6rd: honor tunlink in host dependency
authorSteven Barth <cyrus@openwrt.org>
Thu, 26 Feb 2015 07:42:12 +0000 (07:42 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 26 Feb 2015 07:42:12 +0000 (07:42 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 44541

package/network/ipv6/6rd/Makefile
package/network/ipv6/6rd/files/6rd.sh

index 82195c8c3bad9a43a81baa1485be45f41d143221..d3e4bf69746d6840c65619b4859ede93d8958cfe 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=7
+PKG_VERSION:=8
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
@@ -19,7 +19,7 @@ define Package/6rd
   CATEGORY:=Network
   DEPENDS:=+kmod-ipv6 +kmod-sit
   TITLE:=6rd configuration support
-  MAINTAINER:=Stéphan Kochen <stephan@kochen.nl>
+  MAINTAINER:=Steven Barth <cyrus@openwrt.org>
   PKGARCH:=all
 endef
 
index 042d98559fdce29d6ad9c4d92fd3f09e6389ca0b..287f569885a32b5cd1eee5b8aace2e0966a05969 100644 (file)
@@ -23,7 +23,7 @@ proto_6rd_setup() {
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+       ( proto_add_host_dependency "$cfg" 0.0.0.0 "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"